Asked  1 Year ago    Answers:  5   Viewed   4.5k times

So i just updated to a new Visual studio version and I'm no longer able to push/pull from/to my azure git repo (cloning works fine).

The exact error I get is

Cannot determine the organization name for this '' remote url. ensure the credential.usehttppath configuration value is set, or set the organization name as the user in the remote url '{org}'.

and only the pull command shows me this error, all the others are failing with git fatal error. I messed with my Credentials Manager cos i suspected it might be the one causing the problem but no luck..



What fixed the issue for me is going to Tools > Options > Source Control > Git Global Settings, there I changed all 4 dropdowns which were still selected as "Unset":

  • Prune remote branches during fetch - False
  • Rebase local branch when pulling - False
  • Cryptographic network provider - OpenSSL
  • Credential helper - GCM Core


Note: These are the settings my organization requires. You might have to tweak them around according to your exact issue.

Monday, December 26, 2022

It’s mainly caused by the credentials have been remembered by Credential Manager. You should remove the credentials for which have been stored in Credential Manager.

Such as if the pc’s OS is windows, you can open Credential Manager -> Windows Credentials -> under Generic Credentials -> remove the credentials like git:

Then clone again, git will let you input the credential for the repo. After inputing the username(email address) and password which can access the VSTS account, the repo should be cloned successful.

Tuesday, August 2, 2022

You should specify formGroupName for nested controls

<div class="panel panel-default" formGroupName="address"> <== add this
    <div class="panel-heading">Contact Info</div>

Plunker Example

Tuesday, November 29, 2022

Ok. I solved my question. I think I'm getting timeout when git says "deltafying objects". Because my upload speed is very low thanks to TTNET ( internet provider in Turkey, which sucks )

So, I tried to do this with my company internet; It's uploaded in 1 minutes. Thanks for help though...

Wednesday, November 16, 2022
  1. On the receiving end you normally receive a 414 Request-URI Too Long-header.
  2. No it cannot be increased at runtime. And in Apache, if you use that as a webservers, you can limit it to something below the default 8190 bytes, but not to something above it without changing the source code & recompiling.
  3. Yes, is it server dependent, and even UA-dependent, and if you run Suhusoin with PHP, even more possible rules apply.
  4. If you need to ask "What is the maximum lenght of an url?", you actually need to ask: "Why are these not POST values?".
Sunday, September 11, 2022
Only authorized users can answer the search term. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :

Browse Other Code Languages