Viewed   5.1k times

I am trying to implement log4j 2 but it keeps throwing the following error.

> ERROR StatusLogger Log4j2 could not find a logging implementation.
> Please add log4j-core to the classpath. Using SimpleLogger to log to
> the console...  
> ERROR LogExample This Will Be Printed On Error 
> FATAL LogExample This Will Be Printed On Fatal

I have tried the solution given on the net. But the don't seem to be working for me.

This is the code that I am trying to run.

package demo;

import org.apache.logging.log4j.LogManager;
import org.apache.logging.log4j.Logger;

public class LogExample {

    private static final Logger LOG = LogManager.getLogger(LogExample.class);

    public static void main(String[] args) {

        LOG.debug("This Will Be Printed On Debug");"This Will Be Printed On Info");
        LOG.warn("This Will Be Printed On Warn");
        LOG.error("This Will Be Printed On Error");
        LOG.fatal("This Will Be Printed On Fatal");"Appending string: {}.", "Hello, World");


Project and dependency added in the pom.xml:

Any help is appreciated.



Solved the error message by setting the system property for log4j2 configuration file. below is the below code.


Logger log = LogManager.getLogger(LogExample.class.getName());
Tuesday, August 23, 2022

Below is the code I used to do this given a Java 1.5 file. I'm very new to this and spent today browsing around, and trying things out to get the code below working.

public void processJavaFile(File file) {
    String source = FileUtils.readFileToString(file);
    Document document = new Document(source);
    ASTParser parser = ASTParser.newParser(AST.JLS3);
    CompilationUnit unit = (CompilationUnit)parser.createAST(null);

    // to get the imports from the file
    List<ImportDeclaration> imports = unit.imports();
    for (ImportDeclaration i : imports) {

    // to create a new import
    AST ast = unit.getAST();
    ImportDeclaration id = ast.newImportDeclaration();
    String classToImport = "";
    unit.imports().add(id); // add import declaration at end

    // to save the changed file
    TextEdit edits = unit.rewrite(document, null);
    FileUtils.writeStringToFile(file, document.get());

    // to iterate through methods
    List<AbstractTypeDeclaration> types = unit.types();
    for (AbstractTypeDeclaration type : types) {
        if (type.getNodeType() == ASTNode.TYPE_DECLARATION) {
            // Class def found
            List<BodyDeclaration> bodies = type.bodyDeclarations();
            for (BodyDeclaration body : bodies) {
                if (body.getNodeType() == ASTNode.METHOD_DECLARATION) {
                    MethodDeclaration method = (MethodDeclaration)body;
                    System.out.println("name: " + method.getName().getFullyQualifiedName());

This requires the following libraries:

Thursday, November 24, 2022

If you are using the Xcode 7 GM build version 7A218, the chances are that you accidentally downloaded iOS 9.1 (13B5110e) as opposed to the iOS 9 GM build (13A340). I did the same thing don't worry. They are too close to each other on the downloads page :0

You can check which version you have on your device by simply going to your device Settings > General > About > Version

All you have to do is download the correct iOS 9 GM build and go to iTunes. Click on your device. In the summary tab, OPTION + Right Click "Check for Update" and restore your device by navigating to the iOS 9 GM build finder location. Note by selecting "Check for Update" you will not lose any settings or data on your device. In other words, it is not a restore

However, if you are using Xcode 7.1 build version (7B60) iOS 9.1 is supported

Sunday, November 6, 2022

According to this AWS Support Forum response by an AWS person this problem doesn't affect the working of the DynamoDB local instance.

They do intend to fix it so that the messages isn't displayed but it doesn't make a functional difference.

I haven't yet managed to make my local instance work but there may be other, un-associated, issues with that.

Saturday, November 12, 2022

No. Helios does not support Java 7 syntax. It is also an over three year old product. Kepler just came out. Last year Juno came out. The year before Indigo came out. Before THAT Helios came out.

Why can't you upgrade your Eclipse?

Thursday, September 1, 2022
Only authorized users can answer the search term. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :