Viewed   106 times

I have added "illuminate/html": "5.*" to composer.json and ran "composer update".

  - Installing illuminate/html (v5.0.0)
    Loading from cache

I ran this command in the root of the website. I modified the composer.json file in /root/.composer... and in the root of the project and neither have made a difference.

This downloaded the class and it seemed to install. I have added the following to file config/app.php.


    'Form'      => 'IlluminateHtmlFormFacade',
    'Html'      => 'IlluminateHtmlHtmlFacade',

I think I have an idea what is wrong, but I don’t know how to fix it. My install is in '/var/www/website'. I have checked the file path and the Html folder does not exist.


I was able to find the class files, but in a different directory.


I manually copied the files over to the main Laravel illuminate/html folder, but this hasn't worked either.



This may not be the answer you're looking for, but I'd recommend using the now community maintained repository Laravel Collective Forms & HTML as the main repositories have been deprecated.

Laravel Collective is in the process of updating their website. You may view the documentation on GitHub if needed.

Tuesday, August 30, 2022

Searching on google I found this

"By default in Laravel 5.0, Html and Form are not embedded anymore."

You need to add this package to you application.

Sunday, October 23, 2022

I fixed it by installing the missing dependencies.

1008  php -v
1009  yum search php55
1010  yum -y install php55w-xml.x86_64 
1011  clear
1012  su - api
1013  httpd restart
1014  service httpd restart
Sunday, December 18, 2022

You can use the autoload mapping in order to adchieve that. Just create a folder with the file/files that you want to use. For example:


And store the files right there. Then you just have to use the composer classmap: Edit the composer.json file indicating the path to your classes:

"autoload": {
    "classmap": [

Run the composer dump-autoload command and you'll be ready to go.

Friday, September 30, 2022

It is Input and not input. This commit removed Input facade definition from config/app.php hence you have to manually add that in to aliases array as below,

'Input' => IlluminateSupportFacadesInput::class,

Or You can import Input facade directly as required,

use IlluminateSupportFacadesInput;
Saturday, August 20, 2022
Only authorized users can answer the search term. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :