Viewed   91 times

I have successfully installed php70 and mysql. But when i am trying to install phpmyadmin by

$ sudo yum-config-manager --enable epel

And Then

$ sudo yum install -y phpMyAdmin

It gives me

--> Finished Dependency Resolution
Error: php70-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Also after google sometimes i found a solution that try this

sudo yum install php70-mbstring

And i have tried this also, Still facing same error.

Any suggestion...?



I guess that you are following the Amazon tutorial to install phpMyAdmin ?

I had the same problem today and resolved it by uninstall PHP 7.0 with the yum command (the same given by Amazon with 'remove' instead of 'install' :

sudo yum remove httpd24 php70 mysql56-server php70-mysqlnd

and installed PHP 5.6 instead :

sudo yum install httpd24 php56 mysql56-server php56-mysqlnd

I don't know if this is a good solution, but it worked and I could install phpMyAdmin without dependencies problem. I hope it will help :)

Sunday, September 25, 2022

I couldn't install it directly by YUM either. As I remember, The problem is using CentOS 7 or php7 (in my case).

But you can solve your problem by access here: then download any version you want, and config a little (decompress and copy that folder into /var/www/html/, ...), then you can use phpMyAdmin as normal.

Monday, September 5, 2022

All you need to do instal install package libxml2-dev for example:

sudo apt-get install libxml2-dev


sudo yum install libxml2-devel
Wednesday, December 7, 2022

When looking at this article (How to enable phpMyAdmin or phpPgAdmin to be accessed remotely?), I needed to be looking at Virtual Machine and not Amazon cloud / Bitnami Hosting.

When I changed the /opt/bitnami/apps/phpmyadmin/conf/httpd-app.conf file to the following, I was able to access via [PUBLIC_DNS/YOUR_DOMAIN_NAME/IP]/phpmyadmin].

Main changes being:

Allow from all


Require all granted

After the changes, remember to restart apache server. (or reboot your instance)

sudo /opt/bitnami/ restart apache


<Directory "/opt/bitnami/apps/phpmyadmin/htdocs">
# AuthType Basic
# AuthName phpMyAdmin
# AuthUserFile "/opt/bitnami/apache2/users"
# Require valid-user
AllowOverride None

<IfModule php5_module>
        php_value upload_max_filesize 80M
php_value post_max_size 80M

<IfVersion < 2.3 >
Order allow,deny
Allow from all
Satisfy all
<IfVersion >= 2.3>
Require all granted
ErrorDocument 403 "For security reasons, this URL is only accesible using localhost ( as the hostname"

Docs Ref:

Monday, September 5, 2022

The issue was fixed after I removed

Alias /phpMyAdmin /usr/share/phpMyAdmin



And then don't forget to restart by using the following command

sudo service httpd restart
Friday, August 26, 2022
Only authorized users can answer the search term. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :